新时代到来?jQuery 1.9将是最后一个支持IE6/7/8的版本

jQuery 1.9正式版删除和改动了许多过时API,这将导致很多的代码需要升级重写,虽然官方很友善的提供了升级指南,但对于大部分开发者而言jQuery 1.9还是带来了一些麻烦.

但是这还不够,目前处于Beta期的jQuery 2.0还将放弃支持IE6,IE7,IE8,奔向HTML5.这意为着jQuery 1.9将是最后一个支持IE6/7/8的版本.对于国外的大多数网站而言,IE6的份额已经非常低,是时候去更新了.但对于国内的环境,就不那么适用了,不过也总是有那么一些只使用 HTML5的”顽固分子”(比如博主我),这对于他们来说应该是一个好消息.

jQuery作为现在使用人数最多,人气最高的JavaScript库,也已经要投入HTML5的怀抱了?还在使用xhtml和html4的你究竟在等什么?